UKZN DATA's Proxy Settings (Samsung Galaxy Tab 2)

UKZN DATA's Proxy Settings (Samsung Galaxy Tab 2)

Postby Lola Whiteley » Sat Mar 01, 2014 1:23 pm

Hi, Tech Guy.

I can't have been the only one to notice that the Wi-Fi at UKZN (Howard) is about as reliable as a stoned rabbit.

Each time I try to get onto ANY site that isn't UKZN or Learning@UKZN, it says something along the lines of
"The URL you requested cannot be" something, and then "your browser's proxy settings" something something.

Man, all I want to do is Google stuff when I'm bored without restriction.

HELP ME GOOGLE STUFF WHEN I'M BORED WITHOUT RESTRICTION

Please and thank you,
Lola Whiteley

:thumbs:
User avatar
Lola Whiteley
Site Admin
Site Admin
 
Posts: 19
Joined: Tue Jul 09, 2013 9:22 pm
Location: Musgrave, South Africa

Re: UKZN DATA's Proxy Settings (Samsung Galaxy Tab 2)

Postby MattDN93 » Thu May 22, 2014 9:01 pm

Hey, Lola!

I'm glad you asked about this, because nobody wants to be bored, restricted, and without Google. Let's be realistic for a moment though, I suspect a stoned rabbit would do a better job at managing Internet traffic than this current proxy/firewall mishmash.

I have good news, and I have bad news. I'll go with the bad first, to end this on a positive note. The bad news: You cannot access both Learning@UKZN / Office365 (myUKZN) email AND 'regular' sites at the same time. Ask me why? I have no idea. Here's the good news, and what I do know:

On a Windows PC (Mac behaves similarly):

Proxy ON:
You'll be able to access: Facebook, all sites (including InHub) EXCEPT Learning@UKZN ("You'll see a not-so-friendly Appliance Error")

Proxy OFF:
You'll be able to access: Facebook, Learning@UKZN, some sites (mainly NPO/educational) AND InHub. All others will pop up an insidious small box saying "The URL you requested has been blocked."

On an Android device (tested on my Nexus 7, should behave like your Galaxy Tab 2):

Proxy ON:
You'll be able to access: Facebook, most sites (AND Inhub) EXCEPT Learning@UKZN (If it loads, it will do so sporadically.)

Proxy OFF:
You'll be able to access: Facebook, Learning@UKZN, InHub. Most other sites, however, will be blocked. It's a game of luck with other sites, try them, perhaps put a list of ones you CAN access below?

So the TL;DR version is, if you want certain sites,you'll have to turn the proxy off. Once you're done, turn it on again. A bit of experimenting will help in this regard.

How to go about toggling the proxy on and off, you ask?
[NOTE: To see the screenshots, you must be logged in to InHub Forum.]

Windows:
To ENABLE the proxy:
1. Open up Charms (Windows 8.x) or click "start" (Any other Windows) and type "proxy". Select the first option in the list.
Screenshot (5).png


2. In the dialog, click the "connection" tab followed by "advanced"
Screenshot (30).png


3. Make Sure "Automatically detect settings" is off, especially in Windows 8.x (I'm talking system crashes if you don't). CHECK the "Use a proxy server for your LAN, and hit "advanced." Fill in the top box with "bcproxy.ukzn.ac.za" port 8080. Use this server for all connections. Click OK, OK, Apply, and you're set.
Screenshot (32).png



To DISABLE the proxy:
1. Open up Charms (Windows 8.x) or click "start" (Any other Windows) and type "proxy". Select the first option in the list.
Screenshot (5).png


2. In the dialog, click the "connection" tab followed by "advanced"
Screenshot (30).png


3. To keep the proxy OFF, makes sure you UNCHECK boxes as shown. NOTHING should be checked in this dialog. Press OK, Apply, OK and you're done.
Screenshot (31).png


So that's on Windows. Your query is an Android one, I understand, so here's the process for Android (may look slightly different based on your device)

Android:

To ENABLE the proxy:
1. Open up your device's settings menu. This may vary on per device, but it should involve swiping down/up the status bar and hitting "Settings". Then chose "WiFi"
Screenshot_2014-03-01-20-28-39.png


2. In the list of WiFi networks, long press "UKZNDATA" and choose "modify network"
Screenshot_2014-03-01-20-28-53.png


3. Select the "Advanced settings" checkbox. In the "proxy" section that opens up, choose "manual" and use "bcproxy.ukzn.ac.za" with port "8080". Leave the rest blank. IP setting should be "DHCP"
Screenshot_2014-03-01-20-29-03.png


4. Click "Save", and you're good to go!

To DISABLE the proxy:

1. Follow the steps as above. When in the config page, make "proxy" - "none". Click save and you're good to go!
Screenshot_2014-03-01-20-29-10.png


I hope that helped you, Lola, and anyone else potentially reading this. I will update this post if the Internet situation changes, but until then, this checkboxing must continue.

Cheers

"The Tech Guy" ;)
You do not have the required permissions to view the files attached to this post.


Last bumped by MattDN93 on Thu May 22, 2014 9:01 pm.
Check out the blog!
Give the main site a visit ;)
About me

Phone: HTC One S | dualcore 1.5GHz | PAC ROM 4.2.2 // Tablet: ASUS Nexus 7 (2013 model) | Android 4.3 | Stock // HP dv6 Core i7 2630QM | 8GB RAM | Radeon 6770M
Romans 8:38
User avatar
MattDN93
Site Admin
Site Admin
 
Posts: 51
Joined: Fri Jul 05, 2013 6:40 pm


Return to Android/iPhone



Who is online

Users browsing this forum: No registered users

cron